Upgrade Laravel 7 To 8 With Others Laravel Packages Like Laravel Ui - FreeCodeBlog

Last updated: Dec 15, 2021

Do you have any Laravel 7 version projects? Yes. Okay want to upgrade laravel 7 projects? Yes. Which laravel version? Have you used Bootstrap, TailWind CSS, Vue JS, React JS and more plugins to create Laravel 7 projects? Yes. Want to upgrade all plugin that you used to make laravel 7 project? Yes. Don't worry, You can easily use all plugin like bootstrap, tailwind css, react js, vue js, moment js, multi-select, axios and more in laravel 8. If your laravel project version 7 and you really want to upgrade it to laravel 8 version then read this post carefully to see how we can upgrade laravel 7 to 8 with other packages like laravel ui package.

 

Upgrade Laravel 7 To 8 With Others Laravel Packages Like Laravel Ui
Upgrade Laravel 7 To 8 With Others Laravel Packages Like Laravel Ui.

 

Remember: In this tutorial I will add all available package in package list. you can remove any package from package list and upgrade laravel 7 to 8 version. please don't remove common packages like php, laravel, tinker, faker.

 

Open your laravel 7 project with any code editor like atom, vs code. Now open windows 10 cmd and php version command to see current installed php version.

 

php --version

 

The new minimum PHP version is now 7.3.0. laravel 8 require minimum PHP version 7.3.0. Upgrade laravel require packages in composer.json file. you need to upgrade php, laravel, guzzle, laravel ui, laravel socialite, laravel telescope, and more.

 

"require": {
  "php": "^7.3|^8.0",
  "fruitcake/laravel-cors": "^2.0",
  "guzzlehttp/guzzle": "^7.0.1",
  "laravel/framework": "^8.0",
  "laravel/horizon":"^5.0",
  "laravel/passport":"^10.0",
  "laravel/sanctum": "^2.11",
  "laravel/socialite":"^5.0",
  "laravel/telescope":"^4.0",
  "laravel/tinker": "^2.5",
  "laravel/ui": "3.0"
},

 

Now you need to upgrade laravel require dev packages in composer.json file. you need to upgrade facade, phpunit, nunomaduro, sail, and more.

 

"require-dev": {
  "facade/ignition":"^2.3.6"
  "fakerphp/faker": "^1.9.1",
  "laravel/sail": "^1.0.1",
  "mockery/mockery": "^1.4.4",
  "nunomaduro/collision":"^5.0",
  "phpunit/phpunit":"^9.0"
},

 

Now you can run composer update command to upgrade laravel 7 to 8. Now open windows 10 cmd in xampp htdoces project folder and run composer update or install command to upgrade laravel 7 to 8.

 

composer install
composer update

 

If you encounter an error while updating the Composer package, you may need to clear the Composer cache to try again.

 

composer clear-cache
composer clearcache

 

I hope your laravel 7 version will be upgraded to laravel 8 version. read install tailwind css in laravel with laravel ui tutorial to use tailwind css in laravel. You can read laravel ui package setup in laravel 8 with vue 3 tutorial.

 

Okay so this is for today. See you again next tutorials. Thanks

Post Tags
Post Writer
masum7323
Masum Biswas (@masum7323)

My name is Masum Biswas. I'm a full stack developer. I live in Bangladesh and I love to write tutorials and tools that can help to other artisan. I am a big fan of PHP, Javascript, JQuery, Laravel, MySQL, VueJS, Tailwind CSS and Bootstrap from the early stage.

Follow Me On
Related Posts
Upgrade Laravel 5.8 To 8 Version Complete Tutorial

Want to upgrade laravel 5.8 to 8 version? Yes. Still using older Laravel versions like laravel 5.7, 5.8 or higher for your website? If you use a ve... Read More

How To Integrate Google Recaptcha V3 In Laravel 8 Vue 3

As a developer today I will explain you how we can  easy integrate Google's reCAPTCHA technology in your laravel 8 and vue 3 web applicat... Read More

After User Registration Send A Welcome Email Notification In Laravel 8

Read this tutorial carefully to send a welcome email notification in laravel 8 after user registration. Suppose you have a laravel 8 project and no... Read More

Make Laravel User Authentication Using Laravel Ui In Laravel 8 With Vue 2

Install and use laravel ui package in laravel 8 with Vue 2 to make user authentication. Laravel UI is a new first-party package that extracts the U... Read More

How To Use Ckeditor 5 In Laravel 8 With Vue 3

Laravel 8, Vue 3, Ckeditor 5. Do you really want to use ckeditor 5 on laravel 8 with vue 3? Yes. Do you know about ckeditor 5? A little bit. Ckedit... Read More